Website Down: 502 Error Reported on www.formstack.com

Incident Report for Intellistack

Resolved

The issue causing www.formstack.com to return a 502 error has been resolved. The site is now fully operational.
Posted Nov 20, 2025 - 14:30 EST

Investigating

We’re aware that www.formstack.com is currently down and returning a 502 error. Our team is actively investigating the issue.All products, as well as our help sites, remain fully operational and are not impacted by this outage. We’ll provide updates as soon as more information becomes available.
Posted Nov 20, 2025 - 13:45 EST