Some email notifications delayed or not sending

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 12:46 EDT

Update

The issue affecting outbound email deliveries via SendGrid in Formstack Sign has been fully resolved. Email processing has returned to normal.

Note: Any previously failed Sign deliveries will not be automatically resent. If delivery failed during the incident window, those emails will need to be manually resent.
Posted Jul 17, 2025 - 12:46 EDT

Update

We've resolved the email delivery delays affecting Formstack Documents. All email deliveries via SendGrid are processing as expected.

Note: Any previously failed Document deliveries will not be automatically resent. If delivery failed during the incident window, those emails will need to be manually resent.

However, we are still observing intermittent delays and inconsistent delivery of emails sent via SendGrid through Formstack Sign.
We will continue to monitor delivery performance and provide updates as we make progress.
Posted Jul 16, 2025 - 16:10 EDT

Monitoring

We've implemented a fix and are now seeing email deliveries via SendGrid begin to process successfully. However, delivery performance remains slower than usual, and some emails may still experience delays.

We're continuing to monitor the situation closely to ensure full recovery. Thank you for your continued patience.
Posted Jul 15, 2025 - 16:41 EDT

Identified

We’ve identified the root cause of the issue causing outbound emails via SendGrid to remain in a “processing” state. Our team is actively working on a fix and taking steps to restore normal email delivery.

We will provide another update as soon as more information becomes available.
Posted Jul 15, 2025 - 14:28 EDT

Investigating

We are currently investigating an issue where all outbound email deliveries through SendGrid are stuck in a "processing" state. This is affecting the delivery of transactional and system-generated emails from our platform.

Our team is actively working to identify the root cause and restore normal email processing as quickly as possible. We will provide an update as soon as we have more information or a resolution.
Posted Jul 15, 2025 - 12:44 EDT
This incident affected: Formstack Documents (SendGrid SMTP) and Formstack Sign (Email System (SendGrid)).