We continue to see no new user reports, and Export All functionality is working for most customers. We will continue monitoring to ensure full restoration.
Posted Nov 26, 2025 - 15:27 EST
Monitoring
We have mitigated the issue affecting the Export All option for form submissions. Bulk exports are now working for most customers, and we do not anticipate further customer impact at this time
Posted Nov 25, 2025 - 19:20 EST
Update
We are continuing to investigate issues affecting the Export All functionality for form submissions. While the incident is not yet resolved, we have observed intermittent success with bulk exports.
When exports fail: Users can reliably export individual submissions in batches of up to 100 submissions.
Workaround Step 1: From the form's Submission tab, choose how to filter your submissions. Use the search bar to find keywords Use the default filters: Read or Unread to update the view Select Create Filter to make a custom filtered view NOTE: Similar to Conditional Logic, you may choose All or Any criteria options within the filters. Manually check submissions
Our team is actively working toward a permanent fix and will provide additional updates as they become available. We appreciate your patience.
Posted Nov 25, 2025 - 17:53 EST
Update
We are continuing to investigate this issue.
Posted Nov 25, 2025 - 16:26 EST
Investigating
We are currently investigating an issue where the Export All option for submissions is not working as expected. Users attempting to export all submissions at once may experience errors or failed exports. As a temporary workaround, you can select individual submissions or smaller batches and export them successfully.
Posted Nov 25, 2025 - 16:22 EST
This incident affected: Formstack Forms (Main Application).