We have seen consistent improvement in the export all function and jobs are processing at expected rates.
Posted Dec 01, 2025 - 17:45 EST
Monitoring
We’re seeing clear improvements with the “Export All” functionality, and requests are now processing within normal timeframes.
Posted Dec 01, 2025 - 15:01 EST
Update
We are continuing to investigate this issue.
Posted Dec 01, 2025 - 14:20 EST
Investigating
We are investigating an issues affecting the Export All functionality for form submissions.
When exports fail: Users can reliably export individual submissions in batches of up to 100 submissions.
Workaround Step 1: From the form's Submission tab, choose how to filter your submissions. Use the search bar to find keywords Use the default filters: Read or Unread to update the view Select Create Filter to make a custom filtered view NOTE: Similar to Conditional Logic, you may choose All or Any criteria options within the filters. Manually check submissions