Signature Functionality Failing on Forms with Welcome Page

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 15:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 14:10 EDT

Investigating

Our team is investigating the issue with signatures not working on forms using welcome pages and is working toward a resolution.
Posted Jul 02, 2025 - 12:36 EDT
This incident affected: Formstack Forms (Main Application).