Formstack Forms Stripe Integration Issue

Incident Report for Intellistack

Resolved

This incident has been resolved. A small subset of customers using our Stripe integration experienced payment authorization failures. Re-authorizing the Stripe connection restored the ability to accept payments. Learn more about the Stripe Integration here: https://help.formstack.com/s/article/Stripe-2
Posted Sep 16, 2025 - 08:49 EDT

Update

We’re investigating an issue causing payment authorization attempts to fail for a subset of customers using our Stripe integration. Initial findings indicate that re-authorizing the Stripe connection restores the ability to accept payments. Learn more about the Stripe Integration here: https://help.formstack.com/s/article/Stripe-2
Posted Sep 15, 2025 - 16:06 EDT

Investigating

We are investigating an issue where some customers are unable to process payments through the stripe integration on a live form.
Posted Sep 15, 2025 - 13:35 EDT