PHP Errors on Doc merges

Incident Report for Intellistack

Resolved

Monitoring indicates that document merges are operating normally and no new user reports have been received. The issue has been fully resolved.
Posted Nov 24, 2025 - 20:39 EST

Monitoring

A fix has been deployed to production. We now see document merges succeeding at normal rates. We’ll continue to monitor error metrics and user reports to confirm full recovery.
Posted Nov 24, 2025 - 19:54 EST

Identified

The source of the issue has been identified by our engineers and a solution is pending. Estimated time to a fix is approximately 19:45 Eastern US Time.
Posted Nov 24, 2025 - 19:09 EST

Investigating

Formstack Docs is experiencing an issue where customers are seeing PHP errors on document merges. The most common documents affected are .xlsx formats. Our records indicate the problem started at approximately 10:00am Eastern time with an error message like, "Error merging document (word/document.xml): One or more Merge Fields are accessing object data on a non-object.”
Posted Nov 24, 2025 - 10:00 EST
This incident affected: Formstack Documents (API & Document Generation).