Intellistack Cloud Services Impacted

Incident Report for Intellistack

Resolved

Our team is now able to see full recovery across the vast majority of Intellistack products following remediation actions taken by our public cloud provider, AWS.

We apologize for the inconvenience that this incident has caused.
Posted Oct 21, 2025 - 07:54 EDT

Update

We've started seeing continued product experience improvement; however, AWS is still performing remediation actions, and intermittent errors may continue until their work is fully complete.

We appreciate your continued patience and remain committed to full resolution as we work through this situation.
Posted Oct 20, 2025 - 18:08 EDT

Monitoring

We are currently aware of an ongoing incident intermittently impacting Intellistack services due to an outage with our public cloud provider, AWS. We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority and we are closely monitoring the health of AWS services. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation.
Posted Oct 20, 2025 - 15:29 EDT

Investigating

We are currently investigating an issue causing merge jobs to fail in Documents and preventing document uploads in Sign.
Posted Oct 20, 2025 - 13:44 EDT
This incident affected: Formstack Documents (API & Document Generation) and Formstack Sign (Documents).