Formstack Sign - Trial Accounts Unable to be Created

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 17:07 EDT

Identified

We are currently aware of an issue preventing the creation of new trial accounts and changes to features for existing accounts in our Sign product. All core functionality of our Sign product remains fully operational and unaffected
Posted Sep 02, 2025 - 18:06 EDT
This incident affected: Formstack Sign (Main Application).