3rd Party Incident: Google Authentication service is degraded

Incident Report for Intellistack

Resolved

The 3rd party incident affecting Google Authentication Service is now resolved.
Posted Jul 18, 2025 - 11:57 EDT

Monitoring

Google Auth is facing issues, preventing users who rely on this authentication method from logging in. We advise users not to log out, or they may not be able to log in again while the incident is active.
Posted Jul 18, 2025 - 11:37 EDT
This incident affected: FS ID - Login Auth and Admin Panel.