Signature Functionality on Forms

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 13:40 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 13:20 EDT

Identified

We are currently experiencing an issue impacting the signature functionality on our forms. Our engineering team has diagnosed the root cause and is actively working on a resolution. We will provide another update once we have a confirmed fix or significant progress.
Posted Jul 01, 2025 - 12:39 EDT
This incident affected: Formstack Forms (Main Application).