Intermittent Delays in Documents Processing

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 16:26 EST

Identified

We’ve identified an issue affecting how some jobs are queued and processed, which can result in intermittent processing delays. We are actively working to improve processing behavior and restore normal performance.
Posted Jan 23, 2026 - 15:25 EST

Investigating

We are currently investigating intermittent delays with Formstack Documents, where some jobs are being queued. This may cause slower document processing and creation than usual.
Posted Jan 23, 2026 - 13:20 EST
This incident affected: Formstack Documents (API & Document Generation).