Forms: Partial Submissions Unavailable

Incident Report for Intellistack

Resolved

The incident occurred at 9:02 AM EST. A fix was implemented and released, restoring functionality at to 12:15 PM EST, and the issue is now resolved.
Posted Apr 10, 2026 - 12:44 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2026 - 12:24 EDT

Monitoring

Partial Submissions in Formstack Forms were temporarily unavailable. A fix has been implemented and functionality has been restored. We are now actively monitoring the system.
Posted Apr 10, 2026 - 12:21 EDT

Identified

Partial Submissions in Formstack Forms are currently unavailable. The issue has been identified, and the engineering team is actively working on implementing a fix while systems are being closely monitored.
Posted Apr 10, 2026 - 12:06 EDT
This incident affected: Formstack Forms (Main Application).