Formstack Sign: Document Upload Delays and Failures

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:26 EDT

Investigating

We are currently investigating an issue affecting Formstack Sign that may cause failures or delays when uploading documents.
Posted Mar 31, 2026 - 13:22 EDT
This incident affected: Formstack Sign (Documents).