Sign: Blank page when logging in

Incident Report for Intellistack

Resolved

This incident has been resolved. A fix was released and we have confirmed that customers are now able to log in and access the application normally.
Posted Apr 07, 2026 - 10:21 EDT

Monitoring

A fix has been released for the issue causing a blank screen after login. You can now be able to successfully log in and access the application.
Posted Apr 07, 2026 - 10:12 EDT

Identified

We have identified the cause of an issue where customers experience a blank screen after logging in. Our team is actively working on implementing a fix.
Posted Apr 07, 2026 - 09:41 EDT
This incident affected: Formstack Sign (Main Application).