Forms for Salesforce: Form Migration Issues Affecting Large Forms

Incident Report for Intellistack

Resolved

Resolved (Sandbox): The fix for the large form migration issue has been deployed to Sandbox. Customers who were impacted in Sandbox should republish their affected forms to restore expected functionality.

We are currently working to deploy the fix to Production. We will provide another update once the Production fix has been released.
Posted Jul 20, 2026 - 17:12 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 17, 2026 - 16:54 EDT

Identified

We have identified an issue affecting form migrations for a limited number of customers with very large forms. These migrations may fail or experience unexpected issues.

While our team works toward a resolution, please refrain from migrating very large forms.

We do not expect to have a substantive update before Monday, July 20. We will share additional information as it becomes available.

Thank you for your patience and understanding.
Posted Jul 17, 2026 - 16:31 EDT

Investigating

We have identified an issue impacting the migration of large forms.

While our team investigates, please refrain from migrating large forms to avoid potential issues or failed migrations.

We are actively working to identify the root cause and will provide updates as more information becomes available.

Thank you for your patience and understanding.
Posted Jul 17, 2026 - 16:14 EDT
This incident affected: Formstack for Salesforce (Salesforce Application, Hosted Forms, Form Pre-fill).