Confirmation Emails

Incident Report for Intellistack

Resolved

The incident has been resolved
Posted Aug 25, 2026 - 08:45 EDT

Monitoring

A fix has been implemented and we are monitoring results
Posted Aug 25, 2026 - 08:35 EDT

Investigating

We've identified an issue affecting confirmation emails sent through Formstack Forms. The Confirmation emails from forms are currently delayed or not being delivered, including test emails sent from the settings screen. Notification emails remain unaffected.
Posted Aug 25, 2026 - 08:25 EDT
This incident affected: Formstack Forms (Email System (SendGrid)).