Forms: Intermittent Phone Field Issue

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 12:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 11:25 EDT

Investigating

We are currently investigating an intermittent issue affecting some users who are unable to fill out the phone number or email fields on forms. Our engineering team is actively working to identify the cause and implement a fix.
We will provide updates here as soon as more information becomes available.
Posted Aug 26, 2025 - 11:01 EDT
This incident affected: Formstack Forms (Forms (Hosted & Embedded)).