This incident has been resolved, and emails are now being sent properly. There is no customer action required. Microsoft SMTP clients do NOT need to re-authenticate at all, as Formstack engineers were able to restore the connection without this. Submissions that came into the system between approximately 3:00 pm and 8:20 pm Eastern time on July 30th did not send Confirmation or Notification emails via Microsoft SMTP. Those emails are lost, and customers are not able to re-send those.
Posted Jul 30, 2025 - 20:26 EDT
Update
Formstack engineers are investigating a method where customers do not need to re-auth their Microsoft connection. They are testing that possibility now. ETA on that answer is 30 minutes (8:30pm Eastern).
Posted Jul 30, 2025 - 20:04 EDT
Monitoring
The Formstack engineers have implemented a fix for this Microsoft SMTP issue, however customer emails are not yet delivering.
If you are not using Microsoft SMTP on your Forms account, emails are sending properly and no action is required.
Posted Jul 30, 2025 - 19:48 EDT
Identified
The issue has been identified and Formstack engineers are working on a solution. There is no ETA of resolution at this time.
Posted Jul 30, 2025 - 19:10 EDT
Investigating
Forms customers who have a SMTP connection using Microsoft OAuth are not receiving emails from Forms, such as Notification and Confirmation emails. The errors started approximately 3:05PM Eastern time on July 30th.
Posted Jul 30, 2025 - 18:27 EDT
This incident affected: Formstack Forms (Forms (Hosted & Embedded)).