SIGN: issues with creating new documents in SIGN

Incident Report for Intellistack

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 21:11 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 15:31 EST

Identified

The process appears to be hanging and remains on a continuous loading spinner. The issue has been identified, and the estimated time to resolution is around 4:00 PM Eastern.
Posted Dec 09, 2025 - 14:44 EST
This incident affected: Formstack Sign (Documents).