Our team is now able to see full recovery across the vast majority of Intellistack products following remediation actions taken by our public cloud provider, AWS.
We apologize for the inconvenience that this incident has caused.
Posted Oct 21, 2025 - 07:55 EDT
Update
Our public website formstack.com is now operational again. All Formstack products and customer systems remain fully operational. We are continuing to monitor to ensure full stability
Posted Oct 20, 2025 - 13:14 EDT
Update
Our public website formstack.com is currently experiencing downtime. All products and customer systems remain fully operational and are not affected.
Posted Oct 20, 2025 - 12:19 EDT
Monitoring
All Intellistack services are now fully operational and stable. SMS message delivery has resumed successfully, and we’re observing normal performance and delivery rates across all products.
While our upstream provider (Twilio) continues to list an active incident on their status page, our monitoring confirms that SMS messages are being sent and received as expected.
Posted Oct 20, 2025 - 09:26 EDT
Identified
We are currently experiencing an outage impacting all SMS functionality across our platform. Our third-party SMS provider, Twilio, is reporting a widespread incident that is preventing message delivery.
Posted Oct 20, 2025 - 06:01 EDT
This incident affected: Streamline and Formstack Sign (SMS Delivery).